Appveyor builds for Windows are failing since about Aug 21

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Appveyor builds for Windows are failing since about Aug 21

alvinpenner
as far as I can tell, the first failed build is:

https://ci.appveyor.com/project/inkscape/inkscape/build/improveSPIlength-1492

Warning: Missing dependency libicuin61.dll (libcdr-0.1.dll)
Warning: Missing dependency libicuuc61.dll (libcdr-0.1.dll,
libvisio-0.1.dll)
Warning: Unused dependency libicuin62.dll

Error: missing libraries in installed project

tia,
Alvin




--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: Appveyor builds for Windows are failing since about Aug 21

alvinpenner
sorry, that reference should probably be:

https://ci.appveyor.com/project/inkscape/inkscape/build/master-1504



--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: Appveyor builds for Windows are failing since about Aug 21

Patrick Storz
Am 31.08.2018 um 01:12 schrieb alvinpenner:

> as far as I can tell, the first failed build is:
>
> https://ci.appveyor.com/project/inkscape/inkscape/build/improveSPIlength-1492
>
> Warning: Missing dependency libicuin61.dll (libcdr-0.1.dll)
> Warning: Missing dependency libicuuc61.dll (libcdr-0.1.dll,
> libvisio-0.1.dll)
> Warning: Unused dependency libicuin62.dll
>
> Error: missing libraries in installed project
>
> tia,
> Alvin

It's an MSYS2 issue:
Someone updated libicu to version 62 but they did not consider
rebuilding all dependent packages (licdr/libvisio in Inkscape's case)
which as a consequence are still looking for the outdated and now
missing .dll.

I already requested a rebuild of the libraries in question last week
(https://github.com/Alexpux/MINGW-packages/pull/4324), so CI builds will
work again as soon as the MSYS2 package repository is updated with the
rebuilt libraries.

Regards,
Patrick

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: Appveyor builds for Windows are failing since about Aug 21

alvinpenner
thanks,
Alvin



--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: Appveyor builds for Windows are failing since about Aug 21

alvinpenner
recent error messages seem to have changed somewhat:

https://ci.appveyor.com/project/inkscape/inkscape/build/svg2_to_svg1-1522

revision is db0a274, 2018-09-05

Warning: Missing dependency libdatrie-1.dll (libthai-0.dll)
Warning: Missing dependency libthai-0.dll (libpango-1.0-0.dll)




--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: Appveyor builds for Windows are failing since about Aug 21

Patrick Storz
Am 05.09.2018 um 16:50 schrieb alvinpenner:
> recent error messages seem to have changed somewhat:
>
> https://ci.appveyor.com/project/inkscape/inkscape/build/svg2_to_svg1-1522
>
> revision is db0a274, 2018-09-05
>
> Warning: Missing dependency libdatrie-1.dll (libthai-0.dll)
> Warning: Missing dependency libthai-0.dll (libpango-1.0-0.dll)

This is an error from a branch which was already fixed in master/0.92.x
for quite some time now...

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: Appveyor builds for Windows are failing since about Aug 21

alvinpenner
thanks,
Alvin




--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel