Change introduced last week requires a newer CMake version than specified - what should the minimum CMake version be set to?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Change introduced last week requires a newer CMake version than specified - what should the minimum CMake version be set to?

Inkscape - Dev mailing list
Dear Inkscape Team,

I found that since a change introduced a week ago the inkscape CMake
files are incompatible with the CMake version which comes with Debian 8,
which is 3.0.2. Ok I should update to 9 ;-)

A question: the inkscape main CMake file mentions minimum version 2.8.2,
which definitely does not work. 3.0.2 also does not work.

CMake Version 3.6.2 does work. According to some googled hints the
specific constructs introducing the incompatibility require at least
CMake 3.2.

My question: what should I set the minimum version to? 3.6.2 since I
tested it with it? Or should I be more relaxed? What is the minimum
version of CMake people are actually using successfully?

Or should the change which introduced the incompatibility with Debian 8
be modified so that it works with older versions of CMake, e.g. 3.0.2?

Best regards,

Michael

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Loading...