Quantcast

ImageMagick-7

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ImageMagick-7

Ken Moffat
As I mentioned last year, ImageMagick has moved onto -7. The -6
version is in maintenance mode.  Much of the structure has changed,
which appears to mke changing the programs which use it complex, but
the headers and libraries themselves can be installed in parallel.

Unfortunately, the main pkgconfig files have the same names, so if
you install both versions then the pkgconfig file will be whichever
version you installed last.

I've been asked if you guys have any development patches to support
ImageMagick-7 ?  But maybe I should just ask if you have any plans
to eventually support the newer version ?

For the moment, I suspect the answer is no - and after looking at
the code I wouldn't achieve anything in a month of sundays.  So, for
my own purposes I have a cunning plan : sed the Makefile in inkscape
to add '6' to all the pkgconfig filenames, and then sed all users
(inkscape, possibly some others) to add the 6 to the names.  Dunno
if I'll manage it, but it looks possible.

ĸen
--
`I shall take my mountains', said Lu-Tze. `The climate will be good
for them.'     -- Small Gods

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ImageMagick-7

Bryce Harrington-3
On Thu, Jan 05, 2017 at 09:57:52PM +0000, Ken Moffat wrote:

> As I mentioned last year, ImageMagick has moved onto -7. The -6
> version is in maintenance mode.  Much of the structure has changed,
> which appears to mke changing the programs which use it complex, but
> the headers and libraries themselves can be installed in parallel.
>
> Unfortunately, the main pkgconfig files have the same names, so if
> you install both versions then the pkgconfig file will be whichever
> version you installed last.
>
> I've been asked if you guys have any development patches to support
> ImageMagick-7 ?  But maybe I should just ask if you have any plans
> to eventually support the newer version ?

If there are patches, they'd be in launchpad.  I haven't heard mention
of anything.  I'd ask suv on IRC, she has a knack for knowing where to
find anything and everything.

Offhand it sounds sensible for us to support the newer version.
 
> For the moment, I suspect the answer is no - and after looking at
> the code I wouldn't achieve anything in a month of sundays.  So, for
> my own purposes I have a cunning plan : sed the Makefile in inkscape
> to add '6' to all the pkgconfig filenames, and then sed all users
> (inkscape, possibly some others) to add the 6 to the names.  Dunno
> if I'll manage it, but it looks possible.

Who provides the pkgconfig files?  ImageMagick?  Would it make sense to
ask them to add the -6?

Bryce

> ĸen
> --
> `I shall take my mountains', said Lu-Tze. `The climate will be good
> for them.'     -- Small Gods
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> Inkscape-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/inkscape-devel

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ImageMagick-7

Ken Moffat
On Thu, Jan 05, 2017 at 10:30:57PM -0800, Bryce Harrington wrote:

> On Thu, Jan 05, 2017 at 09:57:52PM +0000, Ken Moffat wrote:
> >
> > I've been asked if you guys have any development patches to support
> > ImageMagick-7 ?  But maybe I should just ask if you have any plans
> > to eventually support the newer version ?
>
> If there are patches, they'd be in launchpad.  I haven't heard mention
> of anything.  I'd ask suv on IRC, she has a knack for knowing where to
> find anything and everything.
>
> Offhand it sounds sensible for us to support the newer version.
>  
Thanks.  At the moment I don't think any major distro has moved to
IM7 so I suspect most people will regard this as a low priority.

> > For the moment, I suspect the answer is no - and after looking at
> > the code I wouldn't achieve anything in a month of sundays.  So, for
> > my own purposes I have a cunning plan : sed the Makefile in inkscape
> > to add '6' to all the pkgconfig filenames, and then sed all users
> > (inkscape, possibly some others) to add the 6 to the names.  Dunno
> > if I'll manage it, but it looks possible.
>
> Who provides the pkgconfig files?  ImageMagick?  Would it make sense to
> ask them to add the -6?
>
> Bryce
>
Yeah, probably.  For the moment I'm attempting a rough hack, but if
it works I'll then need to look at trying to get a cleaner version
and go to their forums.

Cheers

ĸen
--
`I shall take my mountains', said Lu-Tze. `The climate will be good
for them.'     -- Small Gods

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Loading...