Inkscape and Uniconverter

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Inkscape and Uniconverter

doctormo
Dear Developers,

I need your expertise or history knowlege to understand extensions that
use the uniconverter: http://wiki.inkscape.org/wiki/index.php/Uniconver
tor

On my system (Ubuntu 16.04) the uniconverter is broken, the package
python-uniconv doesn't contain the sk1lib libraries and those libraries
are in fact not available at all to debian, either through apt or
through pypi. There is an option to download from their website, but
random debs you find online seems unseemly.

So my main question is: Have we been shipping broken extensions to all
our linux users? Has anyone noticed?

The debian bug report about the missing library doesn't seem to have
been finished, so I don't even know if up to date ubuntus contain a
fix. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=820748

I did notice the library being shipped in our MacOSX build (and
probably in our windows build) is that complete? Does it work there?

I'd like to get these extensions fixed as part of the inkscape-
extensions-1.0 package of cleanup, code quality and refactoring work.
Any information would be greatly appreciated.

Best Regards, Martin Owens

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: Inkscape and Uniconverter

Mattia Rizzolo
On Wed, Apr 11, 2018 at 10:27:50PM -0400, Martin Owens wrote:
> So my main question is: Have we been shipping broken extensions to all
> our linux users? Has anyone noticed?

well, surely to debian and ubuntu, and actually I haven't received any
report, except that bug you found.

> The debian bug report about the missing library doesn't seem to have
> been finished, so I don't even know if up to date ubuntus contain a
> fix. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=820748

debian buster and ubuntu bionic have removed uniconverter as a result,
if that was your question.

--
regards,
                        Mattia Rizzolo

GPG Key: 66AE 2B4A FCCF 3F52 DA18  4D18 4B04 3FCD B944 4540      .''`.
more about me:  https://mapreri.org                             : :'  :
Launchpad user: https://launchpad.net/~mapreri                  `. `'`
Debian QA page: https://qa.debian.org/developer.php?login=mattia  `-

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Inkscape and Uniconverter

doctormo


On Thu, 2018-04-12 at 09:34 +0200, Mattia Rizzolo wrote:
> debian buster and ubuntu bionic have removed uniconverter as a
> result, if that was your question.

That looks like the case:

https://packages.ubuntu.com/bionic/inkscape

The suggested package uniconverter is gone, so it looks like we're
going to have to rethink that functionality. (thankfully this won't
stop inkscape from being installed as it's not a hard dep)

Thanks Mattia,

Best Regards, Martin Owens

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: Inkscape and Uniconverter

Eduard Braun
In reply to this post by doctormo
Am 12.04.2018 um 04:27 schrieb Martin Owens:
Dear Developers,

I need your expertise or history knowlege to understand extensions that
use the uniconverter: http://wiki.inkscape.org/wiki/index.php/Uniconver
tor

On my system (Ubuntu 16.04) the uniconverter is broken, the package
python-uniconv doesn't contain the sk1lib libraries and those libraries
are in fact not available at all to debian, either through apt or
through pypi. There is an option to download from their website, but
random debs you find online seems unseemly.

So my main question is: Have we been shipping broken extensions to all
our linux users? Has anyone noticed?

The debian bug report about the missing library doesn't seem to have
been finished, so I don't even know if up to date ubuntus contain a
fix. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=820748

I did notice the library being shipped in our MacOSX build (and
probably in our windows build) is that complete? Does it work there?

I'd like to get these extensions fixed as part of the inkscape-
extensions-1.0 package of cleanup, code quality and refactoring work.
Any information would be greatly appreciated.

Best Regards, Martin Owens


Hi Martin,

we do not ship uniconvertor on Windows anymore since updating to Python 2.7 as the (previously included) version of uniconvertor 1.1.5 available for download from
  https://sk1project.net/modules.php?name=Products&product=uniconvertor&op=download
still uses Python 2.6 and therefore was not even compatible with official CPython anymore.

For the time being there are still instructions for using this old version available at
  https://inkscape.org/en/learn/faq/#how-install-uniconvertor-windows
but this basically installs a full Python 2.6 distribution in parallel only to allow running uniconvertor (i.e. not overly sensible)

I guess there are two options:
  • Figure out how to package uniconvertor properly and switch to updated packages.  Source code is available at
      https://github.com/sk1project/uniconvertor
    however it seems active development lately shifted to an updated version of "UniConvertor 2.0" and it's not obvious if usage of either package for Inkscape is straightforward.
  • Drop Uniconvertor and related extensions (especially if we can not motivate anybody to support it properly).
    While I know a few people still use it (there are occasional support requests for it) I think it was mostly used for CDR input which is now provided by libcdr and if it was widely used I suspect we'd see a lot more related questions.

Regards,
Eduard


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel