New to inkscape source code

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

New to inkscape source code

Rahul Manoj
Hi,
I am a college student who is looking to contribute to the inkscape project as I am trying to participate in "google summer of code 2017" . I have some initial trouble compiling the source code when I ran cmake .. . 


The error is as follows:

-- Checking for modules 'gtkmm-3.0>=3.8;gdkmm- 3.0>=3.8;gtk+-3.0>=3.8;gdk-3.0>=3.8;gdl-3.0>=3.4'
--   
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:367 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:532 (_pkg_check_modules_internal)
  CMakeScripts/DefineDependsandFlags.cmake:250 (pkg_check_modules)
  CMakeLists.txt:120 (include)

If someone could guide me on what packages or libraries I have to install I would be grateful,
Rahul Manoj

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: New to inkscape source code

Marc Jeanmougin
Well, as the log reads, cmake was checking for gtkmm-3.0 gdkmm-3.0
gtk+-3.0 gdk-3.0 or gdl-3.0 so those would be my guesses.
("sudo apt install libgtkmm-3.0-dev" and such)

--
Mc

On 03/19/2017 11:48 AM, Rahul Manoj wrote:

> Hi,
> I am a college student who is looking to contribute to the inkscape
> project as I am trying to participate in "google summer of code 2017" .
> I have some initial trouble compiling the source code when I ran cmake .. .
>
>
> The error is as follows:
>
> -- Checking for modules
> 'gtkmm-3.0>=3.8;gdkmm-3.0>=3.8;gtk+-3.0>=3.8;gdk-3.0>=3.8;gdl-3.0>=3.4'
> --  
> CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:367
> (message):
>   A required package was not found
> Call Stack (most recent call first):
>   /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:532
> (_pkg_check_modules_internal)
>   CMakeScripts/DefineDependsandFlags.cmake:250 (pkg_check_modules)
>   CMakeLists.txt:120 (include)
>
> If someone could guide me on what packages or libraries I have to
> install I would be grateful,
> Rahul Manoj
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>
>
>
> _______________________________________________
> Inkscape-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/inkscape-devel
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: New to inkscape source code

Maren Hachmann
In case you need more detail, we just had this question on the forums:
www.inkscapeforum.com/viewtopic.php?f=22&t=32012

Maren

Am 19.03.2017 um 12:08 schrieb Marc Jeanmougin:
> Well, as the log reads, cmake was checking for gtkmm-3.0 gdkmm-3.0
> gtk+-3.0 gdk-3.0 or gdl-3.0 so those would be my guesses.
> ("sudo apt install libgtkmm-3.0-dev" and such)
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel