Path > Object to Path; Extensions > Visualise Path > Measure Path > Area - Not giving correct result

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Path > Object to Path; Extensions > Visualise Path > Measure Path > Area - Not giving correct result

Philip Rhoades
People,

If I draw a rectangle to fit an A4 page and then:

   Path > Object to Path

   Extensions > Visualise Path > Measure Path > Area

with a Scale Factor of 1 and output in m, I should get a result of about
0.06 instead I get about 0.0003 . .

Anyone know what I am doing wrong?

Thanks,

Phil.
--
Philip Rhoades

PO Box 896
Cowra  NSW  2794
Australia
E-mail:  [hidden email]

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Path > Object to Path; Extensions > Visualise Path > Measure Path > Area - Not giving correct result

Christoph Raab
Hi Philipp,
afraid I can't reproduce this. I'm using Inkscape 0.92. I tried with the displau units  (Ctrl+Shift+D) set to px, mm, or in. Can you say any more about your setup?
Thanks,
Christoph

On Mon, Jul 17, 2017 at 9:18 AM, Philip Rhoades <[hidden email]> wrote:
People,

If I draw a rectangle to fit an A4 page and then:

  Path > Object to Path

  Extensions > Visualise Path > Measure Path > Area

with a Scale Factor of 1 and output in m, I should get a result of about 0.06 instead I get about 0.0003 . .

Anyone know what I am doing wrong?

Thanks,

Phil.
--
Philip Rhoades

PO Box 896
Cowra  NSW  2794
Australia
E-mail:  [hidden email]

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-user


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Path > Object to Path; Extensions > Visualise Path > Measure Path > Area - Not giving correct result

Brynn
In reply to this post by Philip Rhoades
There's a Scale Factor setting in the dialog, which I found was not set to 1.
So I set to 1.0.  And also I had to change the units to m.  With all of that, I
got a result of 0.062 square meters (precision of 3).

Does that help?


-----Original Message-----
From: Philip Rhoades
Sent: Monday, July 17, 2017 1:18 AM
To: Inkscape User Community
Subject: [Inkscape-user] Path > Object to Path; Extensions > Visualise Path >
Measure Path > Area - Not giving correct result

People,

If I draw a rectangle to fit an A4 page and then:

   Path > Object to Path

   Extensions > Visualise Path > Measure Path > Area

with a Scale Factor of 1 and output in m, I should get a result of about
0.06 instead I get about 0.0003 . .

Anyone know what I am doing wrong?

Thanks,

Phil.
--
Philip Rhoades

PO Box 896
Cowra  NSW  2794
Australia
E-mail:  [hidden email]

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-user 


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-user
C R
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Path > Object to Path; Extensions > Visualise Path > Measure Path > Area - Not giving correct result

C R
In reply to this post by Christoph Raab
Lines should probably be set to mm by default. I'm thinking very few
people will care about measuring lines in pixels.

It's always the first thing I do.
-C

On Mon, Jul 17, 2017 at 1:59 PM, Christoph Raab <[hidden email]> wrote:

> Hi Philipp,
> afraid I can't reproduce this. I'm using Inkscape 0.92. I tried with the
> displau units  (Ctrl+Shift+D) set to px, mm, or in. Can you say any more
> about your setup?
> Thanks,
> Christoph
>
> On Mon, Jul 17, 2017 at 9:18 AM, Philip Rhoades <[hidden email]> wrote:
>>
>> People,
>>
>> If I draw a rectangle to fit an A4 page and then:
>>
>>   Path > Object to Path
>>
>>   Extensions > Visualise Path > Measure Path > Area
>>
>> with a Scale Factor of 1 and output in m, I should get a result of about
>> 0.06 instead I get about 0.0003 . .
>>
>> Anyone know what I am doing wrong?
>>
>> Thanks,
>>
>> Phil.
>> --
>> Philip Rhoades
>>
>> PO Box 896
>> Cowra  NSW  2794
>> Australia
>> E-mail:  [hidden email]
>>
>>
>> ------------------------------------------------------------------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>> _______________________________________________
>> Inkscape-user mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/inkscape-user
>
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> Inkscape-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/inkscape-user
>

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Path > Object to Path; Extensions > Visualise Path > Measure Path > Area - Not giving correct result

Philip Rhoades
People,



On 2017-07-18 01:30, C R wrote:
> Lines should probably be set to mm by default. I'm thinking very few
> people will care about measuring lines in pixels.


Doesn't make any difference - I still get 0.0003 . .

I am using:

   inkscape-0.92-5.pre2.fc25.x86_64

Thanks,

P.


> It's always the first thing I do.
> -C
>
> On Mon, Jul 17, 2017 at 1:59 PM, Christoph Raab <[hidden email]>
> wrote:
>> Hi Philipp,
>> afraid I can't reproduce this. I'm using Inkscape 0.92. I tried with
>> the
>> displau units  (Ctrl+Shift+D) set to px, mm, or in. Can you say any
>> more
>> about your setup?
>> Thanks,
>> Christoph
>>
>> On Mon, Jul 17, 2017 at 9:18 AM, Philip Rhoades <[hidden email]>
>> wrote:
>>>
>>> People,
>>>
>>> If I draw a rectangle to fit an A4 page and then:
>>>
>>>   Path > Object to Path
>>>
>>>   Extensions > Visualise Path > Measure Path > Area
>>>
>>> with a Scale Factor of 1 and output in m, I should get a result of
>>> about
>>> 0.06 instead I get about 0.0003 . .
>>>
>>> Anyone know what I am doing wrong?
>>>
>>> Thanks,
>>>
>>> Phil.
>>> --
>>> Philip Rhoades
>>>
>>> PO Box 896
>>> Cowra  NSW  2794
>>> Australia
>>> E-mail:  [hidden email]
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> Check out the vibrant tech community on one of the world's most
>>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>>> _______________________________________________
>>> Inkscape-user mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/inkscape-user
>>
>>
>>
>> ------------------------------------------------------------------------------
>> Check out the vibrant tech community on one of the world's most
>> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
>> _______________________________________________
>> Inkscape-user mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/inkscape-user
>>

--
Philip Rhoades

PO Box 896
Cowra  NSW  2794
Australia
E-mail:  [hidden email]

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Path > Object to Path; Extensions > Visualise Path > Measure Path > Area - Not giving correct result

Philip Rhoades
In reply to this post by Brynn
brynn,


On 2017-07-17 23:00, brynn wrote:
> There's a Scale Factor setting in the dialog, which I found was not
> set to 1. So I set to 1.0.  And also I had to change the units to m.
> With all of that, I got a result of 0.062 square meters (precision of
> 3).
>
> Does that help?


No - like I said, I also used a scaling factor of 1.0 and output in m .
.

P.


> -----Original Message----- From: Philip Rhoades
> Sent: Monday, July 17, 2017 1:18 AM
> To: Inkscape User Community
> Subject: [Inkscape-user] Path > Object to Path; Extensions > Visualise
> Path > Measure Path > Area - Not giving correct result
>
> People,
>
> If I draw a rectangle to fit an A4 page and then:
>
>   Path > Object to Path
>
>   Extensions > Visualise Path > Measure Path > Area
>
> with a Scale Factor of 1 and output in m, I should get a result of
> about
> 0.06 instead I get about 0.0003 . .
>
> Anyone know what I am doing wrong?
>
> Thanks,
>
> Phil.
> --
> Philip Rhoades
>
> PO Box 896
> Cowra  NSW  2794
> Australia
> E-mail:  [hidden email]
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> Inkscape-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/inkscape-user

--
Philip Rhoades

PO Box 896
Cowra  NSW  2794
Australia
E-mail:  [hidden email]

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Inkscape-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Path > Object to Path; Extensions > Visualise Path > Measure Path > Area - Not giving correct result

alvinpenner
I was not clear as to which version this is ( inkscape-0.92-5.pre2.fc25.x86_64 ):

could you attach the rev number that is reported by the Inkscape menu in the item Help->About Inkscape: for example I get: Inkscape 0.92.1 r15371

if possible, could you attach the svg file you are using?
if not, you can attach a file if you submit a bug report at:
https://bugs.launchpad.net/inkscape

Alvin
Loading...