Quantcast

Specify interpreter's version for Python extensions

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Specify interpreter's version for Python extensions

Minglangjun Li
Hi all,

Today many distros make Python 3 as a default. While some existing Inkscape python 
extensions are not Python 3 compatible (or vice versa). So maybe I think its better to 
encourage extension developers to write code that support both Python 2 and 3 at 
somewhere on the website or wiki. For those existing scripts, we can either use 2to3 
to make them compatible or extend our support of Python interpreter to both Python2 
and Python3 (currently only "python" is supported in INX files). I prefer the former way,
though. What do you think?

Regards,
Minglangjun

------------------------------------------------------------------------------
Announcing the Oxford Dictionaries API! The API offers world-renowned
dictionary content that is easy and intuitive to access. Sign up for an
account today to start using our lexical data to power your apps and
projects. Get started today and enter our developer competition.
http://sdm.link/oxford
_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Loading...