missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

alvinpenner
Windows 10, Inkscape 0.92+devel (36c73a7, 2018-09-09)

- when I start Inkscape, I get the following error messages:
- on the menu, the Extensions system is largely missing, see screenshot
attached
missing_extensions.png
<http://inkscape.13.x6.nabble.com/file/t148043/missing_extensions.png>  

Alvin
..................................................
** (inkscape.exe:2000): WARNING **: 06:29:33.402: Unable to open PowerPoint
fontfix file: C:\APP\Temp\inkscape_devel\share\extensions\fontfix.conf
PowerPoint ungrouping compensation in WMF/EMF export will not be available.

** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
Pango version: 1.42.3

** (inkscape.exe:2000): WARNING **: 06:29:34.434: Unknown verb name:
org.inkscape.typography.newglyphlayer

** (inkscape.exe:2000): WARNING **: 06:29:34.434: Unknown verb name:
org.inkscape.typography.newglyphlayer

** (inkscape.exe:2000): WARNING **: 06:29:34.434: Unknown verb name:
org.inkscape.typography.nextglyphlayer

** (inkscape.exe:2000): WARNING **: 06:29:34.434: Unknown verb name:
org.inkscape.typography.nextglyphlayer
Unable to find: org.inkscape.typography.newglyphlayer
Unable to find: org.inkscape.typography.newglyphlayer
Unable to find: org.inkscape.typography.nextglyphlayer
Unable to find: org.inkscape.typography.nextglyphlayer
Unable to find: org.inkscape.help.manual
Unable to find: org.inkscape.help.keys
Unable to find: org.inkscape.help.askaquestion
Unable to find: org.inkscape.help.commandline
Unable to find: org.inkscape.help.faq
Unable to find: org.inkscape.help.relnotes
Unable to find: org.inkscape.help.reportabug
Unable to find: org.inkscape.help.svgspec




--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html


_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

Maren Hachmann
I think you need to wait for them to return, Martin moved them out from
the main repo a couple of hours ago.

Martin, are you going to use a git submodule? Or how will the extensions
be pulled in now?

Maren

Am 09.09.2018 um 12:43 schrieb alvinpenner:

> Windows 10, Inkscape 0.92+devel (36c73a7, 2018-09-09)
>
> - when I start Inkscape, I get the following error messages:
> - on the menu, the Extensions system is largely missing, see screenshot
> attached
> missing_extensions.png
> <http://inkscape.13.x6.nabble.com/file/t148043/missing_extensions.png>  
>
> Alvin
> ..................................................
> ** (inkscape.exe:2000): WARNING **: 06:29:33.402: Unable to open PowerPoint
> fontfix file: C:\APP\Temp\inkscape_devel\share\extensions\fontfix.conf
> PowerPoint ungrouping compensation in WMF/EMF export will not be available.
>
> ** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
> inkex.py from
> C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
> C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
>
> ** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
> inkex.py from
> C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
> C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
>
> ** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
> inkex.py from
> C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
> C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
>
> ** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
> inkex.py from
> C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
> C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
>
> ** (inkscape.exe:2000): WARNING **: 06:29:33.793: Failed to load resource:
> inkex.py from
> C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
> C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
> Pango version: 1.42.3
>
> ** (inkscape.exe:2000): WARNING **: 06:29:34.434: Unknown verb name:
> org.inkscape.typography.newglyphlayer
>
> ** (inkscape.exe:2000): WARNING **: 06:29:34.434: Unknown verb name:
> org.inkscape.typography.newglyphlayer
>
> ** (inkscape.exe:2000): WARNING **: 06:29:34.434: Unknown verb name:
> org.inkscape.typography.nextglyphlayer
>
> ** (inkscape.exe:2000): WARNING **: 06:29:34.434: Unknown verb name:
> org.inkscape.typography.nextglyphlayer
> Unable to find: org.inkscape.typography.newglyphlayer
> Unable to find: org.inkscape.typography.newglyphlayer
> Unable to find: org.inkscape.typography.nextglyphlayer
> Unable to find: org.inkscape.typography.nextglyphlayer
> Unable to find: org.inkscape.help.manual
> Unable to find: org.inkscape.help.keys
> Unable to find: org.inkscape.help.askaquestion
> Unable to find: org.inkscape.help.commandline
> Unable to find: org.inkscape.help.faq
> Unable to find: org.inkscape.help.relnotes
> Unable to find: org.inkscape.help.reportabug
> Unable to find: org.inkscape.help.svgspec
>
>
>
>
> --
> Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html
>
>
> _______________________________________________
> Inkscape-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/inkscape-devel
>



_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

doctormo
On Sun, 2018-09-09 at 15:55 +0200, Maren Hachmann wrote:
> I think you need to wait for them to return, Martin moved them out
> from
> the main repo a couple of hours ago.
>
> Martin, are you going to use a git submodule? Or how will the
> extensions
> be pulled in now?

We need to fix some of these now that we moved them.

I've added them as a sub-module in git, please do:

git pull
git submodule update --init --recursive

To pull. The extensions are pegged at a specific commit in the
extensions repository, so new changes won't be visible until git
submodule update has been run again and then we commit the new link to
the new version peg.

Best Regards, Martin Owens


_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

Maren Hachmann
Can anyone help with updating the automated builds to use this?

Maren

Am 09.09.2018 um 16:17 schrieb [hidden email]:

> On Sun, 2018-09-09 at 15:55 +0200, Maren Hachmann wrote:
>> I think you need to wait for them to return, Martin moved them out
>> from
>> the main repo a couple of hours ago.
>>
>> Martin, are you going to use a git submodule? Or how will the
>> extensions
>> be pulled in now?
>
> We need to fix some of these now that we moved them.
>
> I've added them as a sub-module in git, please do:
>
> git pull
> git submodule update --init --recursive
>
> To pull. The extensions are pegged at a specific commit in the
> extensions repository, so new changes won't be visible until git
> submodule update has been run again and then we commit the new link to
> the new version peg.
>
> Best Regards, Martin Owens
>



_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

Maren Hachmann
I think that should be working again now, Patrick did it, if I
understood that correctly.

Alvin, do the latest builds (when they are ready) work for you?
Note that translated extensions don't show up if you're using a
non-English interface language for Inkscape (probably not an issue for
you, though :), but for others listening in)

Maren

Am 09.09.2018 um 16:29 schrieb Maren Hachmann:

> Can anyone help with updating the automated builds to use this?
>
> Maren
>
> Am 09.09.2018 um 16:17 schrieb [hidden email]:
>> On Sun, 2018-09-09 at 15:55 +0200, Maren Hachmann wrote:
>>> I think you need to wait for them to return, Martin moved them out
>>> from
>>> the main repo a couple of hours ago.
>>>
>>> Martin, are you going to use a git submodule? Or how will the
>>> extensions
>>> be pulled in now?
>>
>> We need to fix some of these now that we moved them.
>>
>> I've added them as a sub-module in git, please do:
>>
>> git pull
>> git submodule update --init --recursive
>>
>> To pull. The extensions are pegged at a specific commit in the
>> extensions repository, so new changes won't be visible until git
>> submodule update has been run again and then we commit the new link to
>> the new version peg.
>>
>> Best Regards, Martin Owens
>>
>
>
>
> _______________________________________________
> Inkscape-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/inkscape-devel
>



_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

alvinpenner
thanks, I'll give it a try as soon as the Appveyor builds become available.
currently they are failing again.

https://ci.appveyor.com/project/inkscape/inkscape/build/master-1529 built,
apparently

https://ci.appveyor.com/project/inkscape/inkscape/build/master-1530 failed

CMake Error at cmake_install.cmake:5843 (file):
file INSTALL cannot find
"C:/msys64/mingw32/lib/python2.7/site-packages/Cannotlocateinstalled-files.txt".


FAILED: CMakeFiles/install.util
cmd.exe /C "cd /D C:\projects\inkscape\build &&
C:\msys64\mingw32\bin\cmake.exe -P cmake_install.cmake"
ninja: build stopped: subcommand failed

Cheers,
Alvin




--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html


_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

Bryce Harrington-3
In reply to this post by doctormo
On Sun, Sep 09, 2018 at 04:17:42PM +0200, [hidden email] wrote:

> On Sun, 2018-09-09 at 15:55 +0200, Maren Hachmann wrote:
> > I think you need to wait for them to return, Martin moved them out
> > from
> > the main repo a couple of hours ago.
> >
> > Martin, are you going to use a git submodule? Or how will the
> > extensions
> > be pulled in now?
>
> We need to fix some of these now that we moved them.
>
> I've added them as a sub-module in git, please do:
>
> git pull
> git submodule update --init --recursive

Hmm.  When we switched to git, we had discussed about git submodules,
but opted to hold off on them for the time being due to worries about
problems like these (user confusion + tool breakage).  No one was
entirely against it, but the convenience vs. complexity trade seemed an
unlikely win at the time, which is why we've been avoiding using it for
2geom and other such things.

Martin, would you mind holding off on switching to use of submodules
in the main code tree until there's been more discussion?  If we do
start using submodules for extensions, then it'd make sense to revisit
using it for 2geom and other things, however if it still looks like a
small convenience for a lot of complexity it may be worth looking at
other approaches.

Bryce

> To pull. The extensions are pegged at a specific commit in the
> extensions repository, so new changes won't be visible until git
> submodule update has been run again and then we commit the new link to
> the new version peg.
>
> Best Regards, Martin Owens
>
>
> _______________________________________________
> Inkscape-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/inkscape-devel


_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

alvinpenner
just tested
https://ci.appveyor.com/project/inkscape/inkscape/build/master-1534
Inkscape 0.92+devel (c2d29ab, 2018-09-09)

result is the same as in original report




--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html


_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

alvinpenner
tested the latest Appveyor build. there are numerous warning messages in the
console. the failed addresses do not exist on my hard drive. the Inkscape
extension menu is empty.

Inkscape 0.92+devel (fe0f9e6, 2018-09-09)
https://gitlab.com/inkscape/inkscape/commit/fe0f9e6bd05ced25ad7e36800b315e1a8bc5476b
https://ci.appveyor.com/project/inkscape/inkscape/build/master-1535/job/5mi7sgghu43p5h9v
……………………………………………………………………….
Appveyor master-1535 console output

** (inkscape.exe:2320): WARNING **: 20:30:01.729: Failed to load resource:
inkex.py from C:\Users\appveyor\AppData\Roaming\inkscape\extensions\inkex.py
or C:/projects/inkscape/share\extensions\inkex.py
** (inkscape.exe:2320): WARNING **: 20:30:01.729: Failed to load resource:
simplestyle.py from
C:\Users\appveyor\AppData\Roaming\inkscape\extensions\simplestyle.py or
C:/projects/inkscape/share\extensions\simplestyle.py
** (inkscape.exe:2320): WARNING **: 20:30:01.729: Failed to load resource:
simpletransform.py from
C:\Users\appveyor\AppData\Roaming\inkscape\extensions\simpletransform.py or
C:/projects/inkscape/share\extensions\simpletransform.py




--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html


_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

Maren Hachmann
Does it work now?

Martin has worked on this. I've got all stock extensions back (but all
third-party extensions have gone missing instead).

Maren

Am 10.09.2018 um 11:46 schrieb alvinpenner:

> tested the latest Appveyor build. there are numerous warning messages in the
> console. the failed addresses do not exist on my hard drive. the Inkscape
> extension menu is empty.
>
> Inkscape 0.92+devel (fe0f9e6, 2018-09-09)
> https://gitlab.com/inkscape/inkscape/commit/fe0f9e6bd05ced25ad7e36800b315e1a8bc5476b
> https://ci.appveyor.com/project/inkscape/inkscape/build/master-1535/job/5mi7sgghu43p5h9v
> ……………………………………………………………………….
> Appveyor master-1535 console output
>
> ** (inkscape.exe:2320): WARNING **: 20:30:01.729: Failed to load resource:
> inkex.py from C:\Users\appveyor\AppData\Roaming\inkscape\extensions\inkex.py
> or C:/projects/inkscape/share\extensions\inkex.py
> ** (inkscape.exe:2320): WARNING **: 20:30:01.729: Failed to load resource:
> simplestyle.py from
> C:\Users\appveyor\AppData\Roaming\inkscape\extensions\simplestyle.py or
> C:/projects/inkscape/share\extensions\simplestyle.py
> ** (inkscape.exe:2320): WARNING **: 20:30:01.729: Failed to load resource:
> simpletransform.py from
> C:\Users\appveyor\AppData\Roaming\inkscape\extensions\simpletransform.py or
> C:/projects/inkscape/share\extensions\simpletransform.py
>
>
>
>
> --
> Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html
>
>
> _______________________________________________
> Inkscape-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/inkscape-devel
>



_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

alvinpenner
there are a number of remaining problems:
running Inkscape 0.92+devel (8a74b4b, 2018-09-10)

1. user extensions in the directory
C:\Users\username\AppData\Roaming\inkscape\extensions
are not found

2. Inkscape generates the following warnings when loaded:
** (inkscape.exe:6884): WARNING **: 12:46:36.626: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

** (inkscape.exe:6884): WARNING **: 12:46:36.626: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

** (inkscape.exe:6884): WARNING **: 12:46:36.626: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

** (inkscape.exe:6884): WARNING **: 12:46:36.626: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

** (inkscape.exe:6884): WARNING **: 12:46:36.626: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

3. dxf output Rev 14 does not work, fails with the messages:
Traceback (most recent call last):
  File "dxf_outlines.py", line 365, in <module>
    e.affect()
  File "inkex/deprecated.py", line 142, in affect
    return self.run(args=args)
  File "inkex/base.py", line 58, in run
    ret = self.effect()
  File "dxf_outlines.py", line 351, in effect
    self.process_group(doc)
  File "dxf_outlines.py", line 298, in process_group
    self.process_group(node)
  File "dxf_outlines.py", line 302, in process_group
    self.process_shape(node, self.groupmat[-1])
  File "dxf_outlines.py", line 202, in process_shape
    p = inkex.parseCubicPath(d)
  File "inkex/cubic_paths.py", line 165, in parseCubicPath
    return CubicSuperPath(parsePath(d))
NameError: global name 'parsePath' is not defined

4. the file simplepath.py is missing, appears to have been relocated to a
new place, namely
C:\APP\Temp\inkscape_devel\share\extensions\inkex\deprecated-simple

APP





--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html


_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel
Reply | Threaded
Open this post in threaded view
|

Re: missing Extensions system in trunk : Windows, 0.92+devel (36c73a7, 2018-09-09)

alvinpenner
Inkscape 0.92+devel (ff0769d, 2018-09-11)

1. warning messages:
** (inkscape.exe:1096): WARNING **: 08:07:55.612: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
** (inkscape.exe:1096): WARNING **: 08:07:55.616: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
** (inkscape.exe:1096): WARNING **: 08:07:55.616: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
** (inkscape.exe:1096): WARNING **: 08:07:55.616: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py
** (inkscape.exe:1096): WARNING **: 08:07:55.616: Failed to load resource:
inkex.py from
C:\Users\penne_000\AppData\Roaming\inkscape\extensions\inkex.py or
C:\APP\Temp\inkscape_devel\share\extensions\inkex.py

2. user extensions in the folder
C:\Users\username\AppData\Roaming\inkscape\extensions
do not work (are not found)

3. the following stock extensions do not work:
a. DXF R14 output
b. Modify Path->Envelope
c. Render->Wireframe Sphere
d. Render->Gear->Gear
e. Document->Doc Info
this list is not complete, just a quick sampling

it appears that some of these problems may be related to the fact that some
python code has been relocated from the folder 'extensions' to the folder
'extensions\inkex\deprecated-simple'. It would be desirable to revert this
change.

Alvin





--
Sent from: http://inkscape.13.x6.nabble.com/Inkscape-Dev-f2781808.html


_______________________________________________
Inkscape-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/inkscape-devel